CCNA Certification

CCNA, CCNP, CCIE Certification News

Using OSPF’s

BSCI exam success, not to mention earning your CCNP, can come down to your OSPF route summarization skills.

There are a few different commands and situations you need to be ready for, and one of these situations is the proper use of the “summary-address” command.

The summary-address command should be used on an ASBR in order to summarize routes that are being injected into the OSPF domain via redistribution. In the following example, four routes are being redisitributed into OSPF on R1, making R1 an ASBR.

interface Loopback16
ip address 16.16.16.16 255.0.0.0
!
interface Loopback17
ip address 17.17.17.17 255.0.0.0
!
interface Loopback18
ip address 18.18.18.18 255.0.0.0
!
interface Loopback19
ip address 19.19.19.19 255.0.0.0
R1(config)#router ospf 1
R1(config-router)#redistribute connected subnets

These four routes are seen on downstream router R2 as External Type-2, the default for routes redistributed into OSPF.

R2#show ip route ospf
O E2 17.0.0.0/8 [110/20] via 172.12.123.1, 00:00:07, Serial0
O E2 16.0.0.0/8 [110/20] via 172.12.123.1, 00:00:07, Serial0
O E2 19.0.0.0/8 [110/20] via 172.12.123.1, 00:00:07, Serial0
O E2 18.0.0.0/8 [110/20] via 172.12.123.1, 00:00:07, Serial0

To summarize networks learned by redistribution, use the OSPF command summary-address. You can probably do this summarization in your head, but do so before continuing with the lab.

R1(config)#router ospf 1
R1(config-router)#summary-address 16.0.0.0 252.0.0.0

Look at the change in R2s OSPF table.

R2#show ip route ospf
O E2 16.0.0.0/6 [110/20] via 172.12.123.1, 00:00:05, Serial0

The external routes have been successfully summarized. Note that the summary route is still marked as an E2 route.

Theres an interesting route installed into R1s OSPF table as well.

R1#show ip route ospf
O 16.0.0.0/6 is a summary, 00:01:51, Null0

When you configure summary routes in OSPF, a route to null0 will be installed into the OSPF routing table. This helps to prevent routing loops. Any packets destined for the routes that have been summarized will have a longer match in the routing table….

C 17.0.0.0/8 is directly connected, Loopback17
C 16.0.0.0/8 is directly connected, Loopback16
C 19.0.0.0/8 is directly connected, Loopback19
C 18.0.0.0/8 is directly connected, Loopback18

O 16.0.0.0/6 is a summary, 00:03:10, Null0
O 12.0.0.0/6 is a summary, 00:07:53, Null0

… and packets that do not match one of the summarized routes but do match the summary route will be dropped.

March 17, 2007 Posted by | BSCI, CCNP | Leave a comment

OSPF Virtual Links

Knowing when and how to create an OSPF virtual link is an essential skill for BSCI and CCNP exam success, not to mention how important it can be on your job!

As a CCNA and CCNP candidate, you know the theory of virtual links, so let’s take a look at how to configure a virtual link, as well as some real-world tips that many CCNA and CCNP study guides leave out!

In this configuration, no router with an interface in Area 4 has a physical interface in Area 0. This means a logical connection to Area 0, a virtual link, must be built.

Tn the following example, R1 and R3 are adjacent and both have interfaces in Area 0. R4 has an adjacency with R3 via Area 34, but R4 has no physical interface in Area 0 and is advertising its loopback 4.4.4.4 into OSPF. R1 doesn’t have the route to that loopback.

R1#show ip route ospf
6.0.0.0/32 is subnetted, 1 subnets
O 6.6.6.6 [110/11] via 10.1.1.5, 01:05:45, Ethernet0
172.23.0.0/27 is subnetted, 1 subnets
O IA 172.23.23.0 [110/74] via 172.12.123.3, 00:04:14, Serial0
7.0.0.0/32 is subnetted, 1 subnets
O 7.7.7.7 [110/11] via 10.1.1.5, 01:05:45, Ethernet0

To resolve this, a virtual link will be built between R3 and R4 through Area 34. The area through which the virtual link is built, the transit area, cannot be a stub area of any kind.

R4(config)#router ospf 1
R4(config-router)#area 34 virtual-link 3.3.3.3
R3(config)#router ospf 12d07h: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 172.23.23.4, Ethernet0

R3(config)#router ospf 1
R3(config-router)#area 34 virtual-link 4.4.4.4
R3(config-router)#^Z
2d07h: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on OSPF_VL0 from LOADING to FULL, Loading Done

A few details worth noting… the virtual link command uses the remote device’s RID, not necessarily the IP address on the interface that’s in the transit area. Also, don’t worry about that error message you see in the output from R3 that is normal and you’ll see it until you finish building the virtual link.

Always confirm the virtual link with show ip ospf virtual-link. If you’ve configured it correctly, the VL should come up in a matter of seconds.

R3#show ip ospf virtual-link
Virtual Link OSPF_VL0 to router 4.4.4.4 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 34, via interface Ethernet0, Cost of using 10
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:00
Adjacency State FULL (Hello suppressed)
Index 2/4, retransmission queue length 1, number of retransmission 1
First 0x2C8F8E(15)/0x0(0) Next 0x2C8F8E(15)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec
Link State retransmission due in 3044 msec

Viirtual links are actually simple to configure, but for some reason they seem to intimidate people. It’s my experience that the error message highlighted in R3’s output above causes a lot of panic, but the only thing that message means is that you’re not finished configuring the virtual link yet.

There are three main misconfigurations that cause 99% of virtual link configuration issues:

  • Using the wrong OSPF RID value
  • Trying to use a stub area as the transit area
  • Failure to configure link authentication on the virtual link when Area 0 is running authentication

That last one is the one that gets forgotten! A virtual link is really an extension of Area 0, and if Area 0 is running link authentication, the virtual link must be configured for it as well. Pay attention to the details. don’t panic when you see the error message on the second router you configure with the virtual link, and you’ll be ready for any virtual link situation on the job or in the CCNA / CCNP exam room!

March 17, 2007 Posted by | BSCI, CCNP, Education, Technology | Leave a comment

Passive Interface Command And OSPF

To pass the BSCI exam and become a CCNP, you have to be aware of the proper use of passive interfaces.

You learned about passive interfaces in your CCNA studies, but here we’ll review the basic concept and clear up one misconception regarding passive interfaces and OSPF.

Configuring an interface as passive will still allow the interface to receive routing updates, but the interface will no longer transmit them.

While the command itself would make you think this command will be applied at the interface level, that is not the case. Below, we’ll configure ethernet0 as a RIP passive interface.

R1(config)#router rip
R1(config-router)#passive-interface ethernet0

Ethernet0 will no longer send RIP routing updates, but will accept them.

The passive interface concept is clear enough with RIP, IGRP, and EIGRP – all rotocols that send routing update packets. But OSPF doesn’t send routing update ackets – OSPF sends link state advertisements.

It’s the inability of the passive interface command to stop LSAs that lead many o think that passive interfaces cannot be used with OSPF.

Even though OSPF does not sent “routing updates” in the form that RIP, IGRP, and IGRP do, you can still configure an OSPF-enabled interface as passive in order o prevent OSPF traffic from exiting or entering that interface.

No OSPF adjacency can be formed if one of the interfaces involved is a passive nterface, and if you configure an OSPF-enabled interface as passive where an djacency already exists, the adjacency will drop almost immediately.

Let’s see that in action. R1 and R2 have an existing OSPF adjacency over their thernet interfaces. In an effort to reduce routing traffic, R1’s e0 interface s configured as passive. The adjacency drops right away.

R1(config)#router ospf 1
R1(config-router)#passive-interface ethernet0
18:31:11: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Ethernet0 from FULL to DOWN,
Neighbor Down: Interface down or detached

Knowing how to use the passive interface command is a vital part of being a  CNP, and of being a master networker. Good luck to you in both of these pursuits!

March 17, 2007 Posted by | BSCI, CCNP, Education, Technology | 1 Comment

Cisco CCNP/BSCI: IPv6 Leading Zero Compression

The BSCI exam and CCNP certification requires that you be well versed in the basics of IP Version 6, or IPv6.

If youre new to IPv6, youll quickly learn that its not exactly just two more octets slapped onto an IPv4 address! IPv6 addresses are quite long, but there are two ways to acceptably shorten IPv6 address expression. To pass the BSCI exam, become a CCNP, and get that all-important understanding of IPv6, youve got to understand these different methods of expressing an IPv6 address. My last IPv6 tutorial discussed zero compression; today well take a look at leading zero compression.

Leading zero compression allows us to drop the leading zeroes from every field in the address. Where we could only use zero compression once in an IPv6 address expression, leading zero compression can be used as often as is appropriate. The key with leading zero compression is that there must be at least one number left in each field, even if that remaining number is a zero.

You sometimes see books or websites refer to leading zero compression as “dropping zeroes and replacing them with a colon”, but that explanation can be a little confusing, since the blocks are separated with a colon to begin with. Youre not really replacing the leading zeroes, youre dropping them.

Lets look at an example of leading zero compression. Taking the address 1234:0000:1234:0000:1234:0000:1234:0123, we have four different fields that have leading zeroes. The address could be written out as it is, or drop the leading zeroes.

Original format: 1234:0000:1234:0000:1234:0000:0123:1234With leading zero compression: 1234:0:1234:0:1234:0:123:1234

Theres no problem with using zero compression and leading zero compression in the same address, as shown here:

Original format: 1111:0000:0000:1234:0011:0022:0033:0044

With zero and leading zero compression: 1111::1234:11:22:33:44

Zero compression uses the double-colon to replace the second and third block of numbers, which were all zeroes; leading zero compression replaced the “00” at the beginning of each of the last four blocks. Just be careful and take your time with both zero compression and leading zero compression and youll do well on the exam and in the real world. The keys to success here are remembering that you can only use zero compression once in a single address, and that while leading zero compression can be used as often as needed, at least one number must remain in each field, even if that number is a zero.

January 5, 2007 Posted by | BSCI, CCNP, Technology | Leave a comment

BSCI Exam Tutorial: An Introduction To BGP

When you´re studying for the BSCI exam on the way to earning your CCNP certification, it´s safe to say that BGP is like nothing you’ve studied to this point.

BGP is an external routing protocol used primarily by Internet Service Providers (ISPs). Unless you work for an ISP today or in the future, you may have little or no prior exposure to BGP. Understanding BGP is a great addition to your skill set – and you have to know the basics well to pass the BSCI exam.

Note that I said “the basics”. BGP is a very complex protocol, and when you pursue your CCIE, you’ll see what I’m talking about. As with all things Cisco, though, when broken down into smaller pieces, BGP becomes quite understandable. You will need to know the basics of BGP as presented in this chapter to pass your BSCI exam – so let’s get started.

BGP Defined:

“An Internet protocol that enables groups of routers (called autonomous systems) to share routing information so that efficient, loop-free routes can be established. BGP is commonly used within and between Internet Service Providers (ISPs).”

There are a couple of terms in there that apply to the protocols you’ve mastered so far in your studies. The term “autonomous system” applies to IGRP and EIGRP as well as BGP; you’ll be indicating a BGP AS in your configurations just as you did with IGRP and EIGRP. And we’re always looking for efficient, loop-free routes, right? As it did with IGRP and EIGRP, “autonomous system” simply refers to a group of routers that is managed by a single administrative body. An autonomous system will use an Interior Gateway Protocol (IGP) such as OSPF or EIGRP to route packets inside the AS; outside the AS, an Exterior Gateway Protocol (EGP) such as BGP will be used.

BGP shares some characteristics with some routing protocols you’ve already studied. BGP supports VLSM, summarization, and CIDR. Like EIGRP, BGP will send full updates when two routers initially become neighbors and will send only partial updates after that. BGP does create and maintain neighbor relationships before exchanging routes, and keepalives are sent to keep this relationship alive.

BGP has some major differences from the IGPs we’ve studied to this point. You’ll hear BGP referred to as a path-vector protocol. As opposed to distance-vector protocols that exchange relatively simple information about available routes, BGP routers will exchange extensive information about networks to allow the routers to make more intelligent routing decisions. This additional BGP path information comes in the form of attributes, and these path attributes are contained in the updates sent by BGP routers. Attributes themselves are broken up into two classes, well-known and optional.

BGP also keeps a routing table separate from the IP routing table.

We´ll take a look at BGP attributes in future BSCI tutorials. In the meantime, keep studying!

Tag: BSCI, BGP

October 23, 2006 Posted by | BSCI | Leave a comment

Cisco CCNP / BSCI Exam: ISIS Hellos And Adjacencies

In my last ISIS tutorial, I mentioned that while ISIS and OSPF are both link state protocols, their actual operation differs greatly.

To pass the BSCI exam and earn your CCNP, you´ll need to know these differences! Today, we´ll take a look at ISIS Hello types and the adjacency types that form through the use of these Hellos.

Hello packets have been mentioned several times with ISIS, and with good reason. Hello packets are the heartbeat of OSPF and ISIS when heartbeats are no longer heard from a neighbor, that adjacency will be dropped. A major difference between OSPF and ISIS is that OSPF has one type of Hello packet, where ISIS actually has three!

An ES Hello (ESH) is send by all End Systems, and all IS devices listen for this Hello. This is how a router (IS) discovers a host (ES).

An IS Hello (ISH) announces the presence of an IS. An IS Hello is sent by all IS devices, and End Systems listen for these hellos.

An IS-to-IS Hello (IIH) is used by an IS to discover other ISes and to form adjacencies with them.

An interesting side note: A router will send an IIH to another router on the link to form or maintain an adjacency, but it will still send an ISH as well in case there are end systems located on that segment.

ISIS and OSPF both create and maintain adjacencies with the Hello packet. Let´s take a look at the rules regarding ISIS adjacencies as well as the adjacency types.

L1 and L2 Hellos are different messages, so an L1 router must exchange Hellos with another L1 router to form an adjacency, just as L2 routers form adjacencies with L2 routers. L1 routers can only form an adjacency with an L2 router if one of the two routers involved is actually an L1/L2 router.

L1 routers must be in the same area in order to form an adjacency. The Hello timers, as well as the MTU, must match between the interfaces used to form the adjacency.

That´s a lot of L1, L2, and L1/L2, isn´t it? Let´s review the adjacencies each router type can form:

L1: Can form adjacency with any L1 in the same area and any L1/L2 in the same area.

L2: Can form adjacency with any L2 in any area, and with an L1/L2 in any area.

L1/L2: Can form adjacency with any L1 in the same area, L1/L2 in any area, and L2 in any area.

Knowing the similarities and differences regarding ISIS and OSPF is vital for CCNP exam success. Take your time, master the fundamentals, and before long the magic letters “CCNP” are behind your name and on your resume!

Tag: CCNP, BSCI

October 23, 2006 Posted by | BSCI, CCNP | Leave a comment

Cisco CCNP / BSCI Certification: The BGP Attribute “MED”

When you’re preparing to pass the BSCI exam and earn your CCNP certification, one of the biggest challenges is learning BGP. BGP is totally different from any protocol you learned to earn your CCNA certification, and one of the differences is that BGP uses path attributes to favor one path over another when multiple paths to or from a destination exist.

Notice I said “to or from”. In earlier free BGP tutorials, I discussed the BGP attributes “weight” and “local preference”. These attributes are used to favor one path to a destination over another; for example, if BGP AS 100 has two paths to a destination in AS 200, these two attributes can be set in AS 100 to favor one path over another. But what if AS 100 wants to inform the routers in AS 200 as to which path it should use to reach a given destination in AS 100?

That´s where the BGP attribute “Multi-Exit Discriminator”, or MED, comes in. The MED value can be set in AS 100 to tell AS 200 which path it should use to reach a given network in AS 100.

As with many BGP attributes, the MED can be set with a route-map. What you need to watch is that there is no “set med” value in route maps. To change the MED of a path, you need to change the metric of that path. Let´s say that there are two entry paths for AS 200 to use to reach destinations in AS 100. You want AS 200 to use the 100.1.1.0/24 path over the 100.2.2.0/24 path. First, identify the two paths with two separate ACLs.

R1(config)#access-list 22 permit 100.1.1.0 0.0.0.255
R1(config)#access-list 23 permit 100.2.2.0 0.0.0.255

Next, write a route-map that assigns a lower metric to the more-desirable path.

R1(config)#route-map PREFER_PATH permit 10
R1(config-route-map)#match ip address 22
R1(config-route-map)#set metric 100
R1(config-route-map)#route-map PREFER_PATH permit 20
R1(config-route-map)#match ip address 23
R1(config-route-map)#set metric 250

Finally, apply the route-map to the neighbor or neighbors.

R1(config-route-map)#router bgp 100
R1(config-router)#neighbor 22.2.2.2 route-map PREFER_PATH out

The key points to keep in mind is that while many BGP attributes prefer a higher value, the MED is basically an external metric – and a lower metric is preferred, just as with the protocols you´ve already studied to earn your CCNA certification.

January 20, 2006 Posted by | BSCI, CCNP | 2 Comments